Some customers are unable to see and create Crmble contacts and deals.
Incident Report for crmble
Resolved
The issue affecting our services has been successfully resolved. Our team has worked diligently to ensure a swift and thorough resolution, and we are now confident that all systems are fully operational.
Posted May 14, 2024 - 17:47 CEST
Identified
We have identified the root cause of the recent issue affecting our services. Our technical team is actively working to implement a solution and restore normal service as soon as possible.
Posted May 14, 2024 - 17:02 CEST
Investigating
Some customers are unable to see and create Crmble contacts and deals.
We are currently investigating this issue
Posted May 14, 2024 - 15:42 CEST
This incident affected: Crmble for Trello Power-up.