Customers unable to open Crmble in some boards
Incident Report for crmble
Resolved
This incident has been resolved
Posted Apr 22, 2024 - 17:02 CEST
Investigating
Some customers are unable to open Crmble in some boards
We are currently investigating this issue
Posted Apr 22, 2024 - 15:46 CEST
This incident affected: Crmble for Trello Power-up.